In this article:
Applicable to
- Twingate Component: Client
- Platform OS: Windows
Overview
This article addresses an issue with the Twingate Windows Client v2025.138 where the Twingate Windows Service may crash, particularly when the device wakes from sleep.
Our engineering team is aware of the issue and is actively working on a permanent solution.
Symptoms
You may be experiencing this issue if you notice the following:
- You are unexpectedly prompted to re-authenticate to Twingate, even if your security policy re-authentication has not expired.
- The Twingate Client shows as disconnected and you are unable to connect to Resources.
- The Twingate Windows Service is stopped and will not start. Windows may automatically stop the service after it crashes multiple times.
Cause
In version 2025.138 of the Twingate Windows Client, the Twingate.Service.exe process can crash due to an unhandled exception. This is most frequently observed when a device wakes from a sleep state.
To confirm this is the issue you are experiencing, you can check the Twingate logs:
- Click on the Twingate Client in the system tray.
- Navigate to Client > More > Troubleshoot > View Logs.
- This will open two File Explorer windows.
Navigate to thelogs
folder inside theTwingate.stg
directory.
The full path is%USERPROFILE%\AppData\Local\Twingate.stg\logs
. - Open the system-events.log file and search for a
[Error] .NET Runtime
entry where theApplication
isTwingate.Service.exe
and the exception information includesSystem.AccessViolationException
.
It will look similar to the snippet below:
[<MM/DD/YYYY HH:MM:SS AM/PM>] [Error] .NET Runtime Application: Twingate.Service.exe CoreCLR Version: 8.0.1625.21506 .NET Version: 8.0.16 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
Workaround
Recommended: Downgrade to a stable version
You can downgrade the Twingate Client to version 2025.72.
- Download Installer (EXE)
- Download Installer (MSI) - for managed device deployments
Optional: Restart the Twingate Service
If you prefer to continue using version 2025.138, you can manually restart the Twingate service when the issue occurs.
- First, re-authenticate in the Twingate Client if prompted. If the Client is unable to connect to the Windows Twingate Service, proceed with the below.
- Open the Start Menu, type
services.msc
, and press Enter. - In the Services window, scroll down and find the Twingate service.
- Right-click on Twingate and select Start. If the service is already running, select Restart.
This should restore connectivity until the next time the service crashes.