In this article:
Applicable to
- Twingate Component: Client
- Platform: Linux
- OS: Ubuntu 24.04
Overview
Twingate Linux Client notifier logs will call out auth.sock errors on Ubuntu 24.04, and fully fail to authenticate or connect to Resources. This primarily happens after an upgrade from older versions of Ubuntu to 24.04 but has also been observed more rarely in fresh installs, but also on network changes during sleep/wake cycle. Putting a Linux device to sleep on network1, and waking the device on network2, can cause these errors to bubble up and for the client to fail.
Cause
NetworkManager attempts to call for network deletions from D-Bus, which fail and results in an inability to create a network path for the Client. This also results in our notifier service elevating the auth.sock failures.
These will be seen with:
twingate-notifier status
17:43:07 [ERROR] Error: auth.sock socket is not found
Workaround
We can workaround this by switching the renderer from NetworkManager
to networkd
within netplan.
Browse to /etc/netplan
and ls
If you have:
/etc/netplan/01-network-manager-all.yaml
...edit with an editor of choice like:
sudo nano 01-network-manager-all.yaml
...and adjust the contents to look like:
network:
version: 2
# renderer: NetworkManager
renderer: networkd
If you have:
/etc/netplan/50-cloud-init.yaml
...edit with an editor of your choice like:
sudo nano 50-cloud-init.yaml
...and adjust contents to look like:
network:
version: 2
# renderer: NetworkManager
renderer: networkd
If neither file exists, create 01-network-manager-all.yaml
and apply the above contents.
Then:
sudo netplan apply
This may give a warning, but it is safe to ignore and you should then be prompted by the notifier to authenticate into your tenant.
Twingate should then prompt the desktop-notifier and open your default browser.
If it does not automatically prompt for auth, issue a twingate stop
and twingate start
.
If you still don't get a Twingate auth prompt, restart and validate the changes have been applied.