In this article:
Applicable to
- Twingate Component: Client
- Platform OS: Windows
Overview
This article addresses an issue with the Twingate Windows Client in versions 2025.138 through 2025.232 where the Twingate Windows Service may crash, particularly when the device wakes from sleep.
Our engineering team is aware of the issue and is actively working on a permanent solution.
Symptoms
You may be experiencing this issue if you notice the following:
- You are unexpectedly prompted to re-authenticate to Twingate, even if your security policy re-authentication has not expired.
- The Twingate Client shows as disconnected and you are unable to connect to Resources.
- The Twingate Windows Service is stopped and will not start. Windows may automatically stop the service after it crashes multiple times.
Cause
In versions 2025.138 through 2025.232 of the Twingate Windows Client, the Twingate.Service.exe process can crash due to an unhandled exception. This is most frequently observed when a device wakes from a sleep state.
To confirm this is the issue you are experiencing, you can check the Twingate logs:
- Click on the Twingate Client in the system tray.
- Navigate to Client > More > Troubleshoot > View Logs.
- This will open two File Explorer windows.
Navigate to thelogsfolder inside theTwingatedirectory.
The full path is%USERPROFILE%\AppData\Local\Twingate\logs. - Open the system-events.log file and search for a
[Error] .NET Runtimeentry where theApplicationisTwingate.Service.exeand the exception information includesSystem.AccessViolationException.
It will look similar to the snippet below:
[<MM/DD/YYYY HH:MM:SS AM/PM>] [Error] .NET Runtime Application: Twingate.Service.exe CoreCLR Version: 8.0.1625.21506 .NET Version: 8.0.16 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
Resolution
Upgrade to Windows Client release 2025.289
To resolve this issue, please update to 2025.289 or later. 2025.289 is available via the below links with the corresponding deployment method.
- Download Installer (EXE)
- Download Installer (MSI) - for managed device deployments