In this article:
Applicable to
- Twingate Component: Client (version 2026.7)
- Platform OS: Windows
Overview
This article addresses a known issue with the Twingate Windows Client in version 2026.7 where there may be an issue with the Client being unresponsive or unexpectedly disconnecting.
Our engineering team is aware of the issue and is actively working on a permanent solution.
Symptoms
Impacted users may observe one or more of the following after a network change event including device power on, reboot, or sleep/wake.
User unable to login to the Client with the error
Could not join network.The connection toggle (slider) spins/pinwheels and then returns to OFF.
The Client disconnects shortly after connecting, or cannot connect at all.
Stopping the Twingate service via services.msc may hang in
Stopping.Rebooting does not always recover the client or service.
Cause
We have identified an edge case with the scenarios:
The device is not connected to a network immediately after sign-in (for example, the network is not set to connect automatically).
DHCP has not yet assigned network configuration to the interface.
A default route is not yet present, preventing the client from identifying a bypass interface
With these scenarios the Client can fail to detect DNS servers from available interfaces and network initialization fails. In some cases, even after connectivity returns, the Client can still fail and become stuck, leaving no clean recovery path without forcefully terminating the Twingate Windows Service (Twingate.Service.exe).
Resolution
Upgrade the Twingate Client to 2026.36
The Twingate Windows Client 2026.36 release includes a fix for the issue at hand. You can navigate to our Downloads page for the latest releases, or use the below links to download the 2026.36 version directly.
- Download Installer (EXE)
- Download Installer (MSI) - for managed device deployments
Note: You may need to terminate the Twingate Windows Service to proceed with the update.
If the Client has faulted, the Twingate Windows Service will be in a zombie state. A manual termination of the Twingate Client will be needed to proceed with the upgrade.
-
Quit the Twingate Client
System tray > Twingate > Quit
-
Close any remaining Twingate processes
Task Manager > end any Twingate-related processes (
Twingate.exe,Twingate.Service.exe)
Further Details
To confirm the issue beyond the stated symptoms occurring on version 2026.7, you can check the Twingate logs.
- Click on the Twingate Client in the system tray.
- Navigate to Client > More > Troubleshoot > View Logs.
- This will open two File Explorer windows
-
%PROGRAMDATA%\Twingate\logs\(C:\ProgramData\Twingate\logs) -
%LOCALAPPDATA%\Twingate\logs\(C:\Users\<username>\AppData\Local\Twingate\logs)
-
-
Search
%PROGRAMDATA%\Twingate\logs\Twingate.Service.logforfailed to initialize libhydra: code -1following the packet manager initialization. In a bad state, we would expect this to continuously looping.[<date_time>] [INFO] [client] Start packet manager initialization. [<no type>.platform_module_new] [<date_time>] [ERROR] [libsdwan] failed to initialize libhydra: code -1 [<no type>.log]
- Search
%LOCALAPPDATA%\Twingate\logs\system-events.log(created after clicking View Logs in the Twingate Client) for both of the below criteria, seeing if there are matching results returned.
-
Search criteria:
Application: Twingate.Service.exe[<date_time>] [Error] .NET Runtime Application: Twingate.Service.exe CoreCLR Version: 8.0.2325.60607 .NET Version: 8.0.23 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt. Stack: at <Module>.PktDevice_WFPBlockTrafficOutsideTun(_PktDevice*, Boolean) ...
-
Search criteria:
P1: Twingate.Service.exe[date_time>] [Information] Windows Error Reporting Fault bucket , type 0 Event Name: APPCRASH Response: Not available Cab Id: 0 Problem signature: P1: Twingate.Service.exe P2: 2026.7.2078.0