In this article:
Applicable to:
- Twingate Component: Connector
Overview
While the Client is working fine, connections to Resources are failing because the Twingate Connector fails to connect to the Twingate Relay architecture.
Symptoms
- Connector is successful with outbound internet traffic and meets all Network Requirements.
- No connections to Resources are possible.
- Connection details in the Twingate Administrator console show Connector unable to connect to the Resource.
Troubleshooting
- You see errors like these in the Connector logs:
[Timestamp][Connecor]: [ERROR] [libsdwan] listen::channel_event: Failed to preconnect a relay listener "ice://any": 110 (Connection timed out)
[Timestamp][Connecor]: : [ERROR] [libsdwan] listen::maintain_relay_connectivity: relay [IP address and port] is not available, disconnect - There may also be messages stating:
resource temporarily unavailable
Cause
The Connector VM instance only has a public IPv6 address assigned to it.
Resolution
Ensure a public IPv4 address is assigned to the Connector instance.