In this article:
Applicable to:
- Twingate Component: Windows Client
- Version: 2024.193
Overview
Windows Client version 2024.193 has been observed to run into an unrecoverable error in some environments. The symptoms resulting from this can be the following–
-
A popup with the below message, without another VPN installed or active.
Unable to Connect
We have detected that another VPN connection is active. Please close that connection before connecting to Twingate. - DNS resolution or the connectivity to Resources may be impacted after waking from sleep or after startup from shutdown.
- Twingate.log | Twingate.<date_time>.log may have the following errors–
[ERROR] [client] Preconnection check failed. AnotherVpnIsRunning details: Twingate TAP-Windows Adapter V9 [ClientPreconnectionChecksRunner.CallService]
[ERROR] [client] Grpc.Core.RpcException: Status(StatusCode="DeadlineExceeded", Detail=""), Status(StatusCode="DeadlineExceeded", Detail="") [ClientGrpcMiddleware.SendMessageAndHandleExceptions]
- Twingate.Service.log | Twingate.Service.<date_time>.log may have the following error–
[ERROR] [client] Failed to send message to the client. ID=520908a7-2ebb-4765-9892-a138f6c8db09. Grpc.Core.RpcException: Status(StatusCode="DeadlineExceeded", Detail="") [ServiceGrpcMiddleware.BroadcastMessage]
Cause
With some system conditions, an unrecoverable error during pre-connection checks may take place. This causes the Twingate Service to exceed the timeout for these checks.
Resolution
Upgrade your Windows Client to 2024.213 or later with the below applicable links–
- Download latest EXE
- Download latest MSI (for devices managed via MDM)
- Additional version information (and MSIs) are available via Twingate Clients Changelog