Client connection fails with “Unknown network name”
Last updated: April 3, 2026
Applicable to
- Twingate Component: Client
- Platform: Windows
- Other software: Antivirus solution (in this case Elastic AV)
Overview
How to resolve an issue where the Twingate client fails to connect and reports “Unknown network name”.
Symptoms
- Twingate client fails to connect and reports “Unknown network name”
- In the Twingate.Service.log we see:
<> [ERROR] ConnectionManager.b__0 ThreadId=15 [SDWAN] controller_t::operator (): failed to get an access token: open_url timeout
<> [ERROR] ConnectionManager.b__0 ConnectionManager Auth failed. errorCode: 602, errorMessage: open_url timeout
- The twingate.log shows errors like these:
<> [DEBUG] ControllerServerValidator.ValidateAsync ControllerServerValidator. Validate uri https://<>.twingate.com/
<> [ERROR] ControllerServerValidator.ValidateAsync Failed to validate controller url
System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
Troubleshooting
- no relevant errors in the Windows event logs
- Verify the Twingate service is running.
- Check to see if you can establish a HTTP connection via powershell. This will utilize .NET Framework, which the Twingate Windows Client uses as well. Issue the below invoke-webrequest command in powershell:
invoke-webrequest -UseBasicParsing -uri "https://.twingate.com" | Select-Object StatusCode
- If you receive the below error instead of a response code, there is something configured or installed on the system preventing the TLS session to complete.
invoke-webrequest : The request was aborted: Could not create SSL/TLS secure channel.
At line:1 char:1
+ invoke-webrequest -UseBasicParsing -uri "https://.twingate.co ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebException
+ FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
- Check to ensure you aren't running into any security, DNS, or remote access software that can conflict with Twingate: Known Incompatibility Overview
Cause
Antivirus / Security software blocks or interferes with the Twingate TLS connection.
Resolution
Adding the Twingate service to the Whitelist in the Antivirus solution (i.e. Elastic), disabling Defender and rebooting the system resolves the issue. Further information about compatibility issues can be found at Known Incompatibility Overview